summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Friesel <derf@derf.homelinux.org>2010-02-05 17:52:34 +0100
committerDaniel Friesel <derf@derf.homelinux.org>2010-02-05 17:52:34 +0100
commit21c4996c71d76b01a4333ef9905589b3fffa687d (patch)
treebbf41aa6c88d6875181f0089273567f47fb58209 /Makefile.am
Initial commit (upstream 1.3.4)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..d082a96
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,26 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = 1.4 foreign
+
+# A list of all the files in the current directory which can be regenerated
+MAINTAINERCLEANFILES = Makefile.in feh.spec
+
+LDFLAGS = -L/usr/X11R6/lib -L/usr/lib -L/usr/local/lib
+INCLUDES = -I/usr/X11R6/include \
+$(X_CFLAGS) -I$(prefix)/include -I$(includedir) -I.
+
+man_MANS = feh.1
+
+docs_DATA = README AUTHORS ChangeLog TODO
+docsdir = $(prefix)/doc/feh
+
+EXTRA_DIST = \
+feh.spec feh.1 $(docs_DATA)
+
+SUBDIRS = src cam
+
+test:
+ (cd src && $(MAKE) test)
+
+testclean:
+ (cd src && $(MAKE) testclean)