summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in78
1 files changed, 0 insertions, 78 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 2badc80..0000000
--- a/configure.in
+++ /dev/null
@@ -1,78 +0,0 @@
-dnl Process this file with autoconf to create configure.
-
-AC_INIT(src/main.c)
-AM_INIT_AUTOMAKE(feh, 1.4.1)
-AM_CONFIG_HEADER(src/config.h)
-
-AC_PROG_CC
-AM_PROG_CC_STDC
-AC_C_CONST
-
-AC_PROG_INSTALL
-AC_PROG_MAKE_SET
-
-AM_MAINTAINER_MODE
-AM_WITH_DMALLOC
-
-AC_ARG_WITH(imlib2,
- [ --with-imlib2=DIR use imlib2 in <DIR>],
- [CFLAGS="$CFLAGS -I$withval/include"
- LIBS="-L$withval/lib $LIBS"])
-
-AC_PATH_GENERIC(imlib2, 1.0.0, [
- AC_SUBST(IMLIB_LIBS)
- AC_SUBST(IMLIB_CFLAGS) ],
- AC_MSG_ERROR(Cannot find imlib2: Is imlib2-config in the path?) )
-IMLIB_LIBS=`imlib2-config --libs`
-IMLIB_CFLAGS=`imlib2-config --cflags`
-AC_SUBST(IMLIB_LIBS)
-AC_SUBST(IMLIB_CFLAGS)
-
-AC_PATH_GENERIC(giblib, 1.2.4, [
- AC_SUBST(GIBLIB_LIBS)
- AC_SUBST(GIBLIB_CFLAGS) ],
- AC_MSG_ERROR(Cannot find giblib: Is giblib-config in the path?) )
-
-dnl the above doesn't work for some reason :/
-GIBLIB_LIBS=`giblib-config --libs`
-GIBLIB_CFLAGS=`giblib-config --cflags`
-AC_SUBST(GIBLIB_LIBS)
-AC_SUBST(GIBLIB_CFLAGS)
-
-dnl Check for Xinerama
-AC_ARG_ENABLE(xinerama,
- AC_HELP_STRING([--disable-xinerama],[disable Xinerama multi screen support]),
- [
- if test x"$enableval" = xyes; then
- with_xinerama="yes"
- else
- with_xinerama="no"
- fi
- ],
- [with_xinerama="detect"]
-)
-if test x"$with_xinerama" != xno; then
- AC_CHECK_LIB(Xext,XMissingExtension,[
- AC_CHECK_LIB(Xinerama,XineramaQueryScreens,[
- AC_DEFINE(HAVE_LIBXINERAMA, [], [Enable Xinerama support])
- LIBS="$LIBS -lXext -lXinerama"
- ])
- ])
-fi
-
-dnl AC_CHECK_FUNC(getopt_long,,[LIBOBJS="$LIBOBJS getopt.o getopt1.o"])
-dnl AC_SUBST(LIBOBJS)
-
-echo "checking for pr0n.... found"
-
-AC_OUTPUT(Makefile \
-feh.spec \
-cam/Makefile \
-src/Makefile \
-src/ttfonts/Makefile \
-)
-
-echo ""
-echo "If you have used an earlier version of feh,"
-echo "please remove your ~/.fehrc config file."
-echo "feh will create a new one when it is first run."