summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Friesel <derf@derf.homelinux.org>2009-07-02 23:22:53 +0200
committerDaniel Friesel <derf@derf.homelinux.org>2009-07-02 23:22:53 +0200
commitfbb52c53dea0aff7ba059edc648192a9febd8b13 (patch)
tree17eb9c6ce497d49047336b9b09243fd5c8e6d805 /Makefile
parent1d9d63a29c8b837f7e6aa9da65c3de3d4242c816 (diff)
makefile → Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..844b806
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+build/apt-why.1: bin/apt-why
+ mkdir -p build
+ pod2man $< > $@
+
+install:
+ install -m 755 bin/apt-why /usr/local/bin
+ install -m 644 -D build/apt-why.1 /usr/local/share/man/man1/apt-why.1
+
+install-completion:
+ install -m 644 provides/zsh/completions/_apt-why \
+ /usr/share/zsh/functions/Completion/Debian
+
+clean:
+ $(RM) -r build
+
+uninstall:
+ $(RM) /usr/local/bin/apt-why
+ $(RM) /usr/local/share/man/man1/apt-why.1
+
+uninstall-completion:
+ $(RM) /usr/share/zsh/functions/Completion/Debian/_apt-why