summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..844b806
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+build/apt-why.1: bin/apt-why
+ mkdir -p build
+ pod2man $< > $@
+
+install:
+ install -m 755 bin/apt-why /usr/local/bin
+ install -m 644 -D build/apt-why.1 /usr/local/share/man/man1/apt-why.1
+
+install-completion:
+ install -m 644 provides/zsh/completions/_apt-why \
+ /usr/share/zsh/functions/Completion/Debian
+
+clean:
+ $(RM) -r build
+
+uninstall:
+ $(RM) /usr/local/bin/apt-why
+ $(RM) /usr/local/share/man/man1/apt-why.1
+
+uninstall-completion:
+ $(RM) /usr/share/zsh/functions/Completion/Debian/_apt-why